My Cloud Home Not Detected, Not Found, Cannot Connect or Device Offline

Issue:

Cannot connect to a My Cloud Home using the Web, Mobile or Desktop App.

 Web App

Mobile App

Desktop App

 

 


Cause:

The possible causes of a My Cloud Home being offline are:

My Cloud Home

  • Not powered on
  • LED is blinking indicating a non-ready state
  • Did not receive a DHCP IP address from the router
  • DHCP IP address changed
  • Disconnected or faulty Ethernet cable
  • System Erase in progress
  • Changing storage modes on My Cloud Home Duo

Computer

  • Firewall, Anti-Virus, Malware, Internet Security or End Point Protection software blocking incoming network queries

Networking

  • Router, Hub or Switch between the Internet facing router and the My Cloud Home
  • Router Security feature blocking local queries, filtering or blocking incoming network traffic
  • ISP filtering or blocking network traffic
  • Issue with remote location network and or DNS servers

Solution:

Topic
Instructions
My Cloud Home Device Click here for Instructions
Networking Click here for Instructions
Computer or Mobile Phone Click here for Instructions
New Device Setup - Slow Breathing LED Click here for Instructions


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