USB Drive Not Seen by a My Cloud Home or Duo

Issue:

My Cloud Home or Duo does not recognize an attached external USB drive.


Cause:

The external USB drive may not be supported by the My Cloud Home and Duo.
Please refer to the solutions below for more details.


Solution:

USB attachment notifications are provided in the My Cloud Home mobile app when a supported external USB drive is attached and the file system is mounted.



If the USB drive is not seen or mounted on the My Cloud Home, follow the solutions below.


My Cloud Home Duo - Second USB Drive

A My Cloud Home Duo will not recognize and mount the second USB drive.
For more details, please refer to Answer ID 20230 My Cloud Home Duo Does Not Recognize The Second USB Drive


Password Protected Drive

Password protected USB drives are not supported.
The password must be removed to use the USB drive with a My Cloud Home.
For more information regarding Unsupported USB drives, please refer to Answer ID 19292 My Cloud Home Unsupported USB Drive Message


Supported File Systems

Ensure the file system used on the USB device is compatible with a My Cloud Home.
For a list of USB drive file systems supported, please refer to Answer ID 18256 My Cloud Home and My Cloud Home Duo USB Compatibility List


USB Cables

A USB cable may work with one computer but not another. Obtaining a high quality replacement or trying a different (longer or shorter) USB cable may resolve your issue


Defective USB Drive

Check the drive for damage and failures
To check the drive, please refer to Answer ID 14920 How to check if a WD drive is damaged or defective


USB Port Power and Dual Powered USB Cable

If the alternate computer can see and access the drive, the primary or other computers USB port may not provide enough power for the external drive.

  • Power from USB ports can vary. The use of a Power Booster cable may be needed in order to provide enough power to the USB drive. A Power Booster cable is a Y-shaped cable, with an extra connector, that allows for connecting a USB device to two USB ports on a computer.

  • A powered USB hub may be needed depending on the power requirements and consumption of the external USB drive.

  • For (My Book) connect the power adapter directly in to a wall socket if available

  • NOTE: This solution is not suitable for My Cloud Home (single bay) that have a single external USB port.

Different Computer

Connect the device to a different computer. If the computer can see and mount the device, check the device for errors.

  1. Use WD Drive Utilities to run a complete drive test.
    For assistance using WD Drive Utilities, please see Answer ID 10408: How to set up and use WD Security & WD Drive Utilities

  2. Perform a Disk Defragmentation:
    • Click on Start (Windows logo) at the bottom-left of the screen
    • Type defrag and press Enter
    • Select the hard drive and click Optimize

  3. Safely eject the drive in Windows and Power Off the Desktop drive if applicable
    Please see Answer ID 15058: Safely removing the USB device from the computer

My Cloud Home Power Cycle


  1. Power OFF the My Cloud Home
  2. Disconnect the external USB drive
  3. Power ON the My Cloud Home
  4. Connect the USB cable directly to the My Cloud Home. Do Not use a non powered USB Hub

Drive Reformat

In some cases, an external drive formatted by one computer may not be seen by a different computer or device. Please follow the steps below if the drive was originally formatted on a different computer:
  1. Connect the external drive to the computer the drive was originally formatted on
  2. Copy or Backup the content to another device
  3. Safely eject the external drive. For assistance, please see Answer ID 15058: Safely removing the USB device from the computer
  4. Connect the external device to the My Cloud Home

Unsupported USB Drives

External USB drives that are not seen by a My Cloud Home or Duo are not supported.
If all of the solutions above have been exhausted and the drive does not mount or is not seen by the My Cloud Home, the drive is not supported.




In case the answer did not answer your question, you can always visit the WD Community for help from WD users.

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