My Cloud Home Desktop Sync and Computer Slow Performance


Issue:

My Cloud Home and computer used to Desktop Sync are suffering from slow performance.


Cause:

The following Desktop Sync conditions can result in slow perfomance of My Cloud Home and the computer used to Desktop Sync.


  • Desktop Sync of large quantities of tiny files
  • Desktop Sync of deeply nested and complex diectory structures
  • Desktop Sync of more than one folder at a time
  • User Mounted Private space performance limitations
  • USB Backups or USB connected to My Cloud Home
  • My Cloud Home operating under high cpu and memory conditions due to iindexing and thumbnail generation of content added
  • Computer operating under high cpu and memory conditions
  • Red X appears on the Sync folder representing a Sync error condition
  • Social Media Import is being utilized at the same time as Sync
  • Plex Enabled, indexing and cataloging the content inside of the Plex folders
  • Computer Software such Anti Virus, Internet Security and End Point Protection

Solution:

My Cloud Home Desktop Performance

For information regarding My Cloud Home desktop app transfer speeds, please refer to Answer ID 19476: My Cloud Home Desktop App Data Transfer Speeds

 

Small Data Sets

Please check the destination after 30 minutes to ensure Sync content appears on the destination.

 

Large Data Sets

Please check the destination after a few hours to ensure Sync content appears on the destination.

 

Reduce Memory and CPU Consumption

Follow the steps below to help reduce Memory and CPU consumption on the My Cloud Home.

 

Disable Services


Disable Social Media Import

  1. Open a web broswer to mycloud.com
  2. Sign In your My Cloud Home account
  3. Click Services
  4. Click on Social and Cloud Import
  5. Click Disable
  6. Click Disable Service at the popup

 

Disable Plex

  1. Open a web broswer to mycloud.com
  2. Sign In your My Cloud Home account
  3. Click Services
  4. Click on Plex
  5. Click Disable
  6. Click Disable Service at the popup

 

Disable Network Import

  1. Open a web broswer to mycloud.com
  2. Sign In your My Cloud Home account
  3. Click Services
  4. Click on Network Import
  5. Click Disable
  6. Click Disable Service at the popup

 

Repeat the process for all remaining My Cloud Home Services

 

 

Desktop Sync

IMPORTANT Important:

Sync Resume on a folder is not supported! When a folder is set to Unsync, Sync to My Cloud on the same folder again will create a new sync folder on the My Cloud Home. For more details regarding duplicate Sync folders, please refer to Answer ID20981 My Cloud Home Desktop Sync Creates Duplicate Folder Names


Please ensure there's copy or backup (not a sync) of all content on the My Cloud Home before modifying any Sync configued folders.


UnSync Sync'd Folders

  1. Locate all Sync'd folders on the computer
  2. Right Click on the Sync'd folder
  3. Click UnSync
  4. Repeat the Unsync process for all remaining "Sync to My Cloud" folders

 

UnSync Red X Folders

  1. Locate all Sync'd folders on the computer with the Red X
  2. Right Click on the folder
  3. Click UnSync
  4. Repeat the Unsync process for all remaining "Sync to My Cloud" folders with a Red X

 

Duplicate Sync Folders On The My Cloud Home


Locate and Move, Rename or Delete as needed to prevent thumbnail generation of duplicate content.
For more details regarding duplicate Sync folders, please refer to Answer ID20981 My Cloud Home Desktop Sync Creates Duplicate Folder Names


IMPORTANT Important:

Please ensure there's copy or backup (not a sync) of all content on the My Cloud Home before modifying any Sync configued folders.


Reboot

  1. Open a web broswer to mycloud.com
  2. Sign In your My Cloud Home account
  3. Click Settings
  4. Click "Your Name's" My Cloud Home under CURRENT STORAGE
  5. Scroll Down
  6. Click Reboot Device
  7. Click Reboot

 

Best Practices

Follow the suggested Best Practives below to allow the My Cloud to process and generate thumbnails to prevent a High Memory or CPU Condition.


  • Sync one folder at a time
    Allow the Sync and thumbnail generation of content to complete 100% before starting another operation

  • Import one social media or cloud storage at a time
    Allow the import and thumbnail generation of content to complete 100% before starting another operation

  • USB Backup one USB drive at a time
    Allow the import and thumbnail generation of content to complete 100% before starting another operation



In case the answer did not answer your question, you can always visit the WD Community for help from WD users.

Please rate the helpfulness of this answer